開発環境構築

開発環境構築

デバイスドライバをビルドするためには、カーネルバージョンと同一バージョンの、kernel-develとkernel-headersパッケージが必要です。

そのため、まずは自身の環境のカーネルバージョンと上記2つのパッケージがインストールされているかどうかを調べます。

# uname -r
2.6.18-238.el5
# rpm -aq | grep kernel
kernel-headers-2.6.18-238.el5
kernel-devel-2.6.18-238.el5

上記例では、カーネルのバージョンが「2.6.18-238.el5」であり、同バージョンのkernel-develとkernel-headersパッケージがインストールされています。

もし、インストールされていないのであれば、yumなどを使いインストールします。


# yum install kernel-devel
# yum kernel-headers


yumでバージョンが揃わなければ、rpmなど別の方法でインストールすることになります。

タグ